Delays in envelope completion

Incident Report for Digisign

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 08:58 CEST

Investigating

We are experiencing delays in the application when completing envelopes. Envelopes may remain in the "Sealed" status longer than usual. We are currently investigating the issue.
Posted Jul 17, 2026 - 08:47 CEST
This incident affected: DigiSign eSignature (Queue).