Delays in application response

Incident Report for Digisign

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 13:21 CEST

Investigating

We are experiencing a high queue volume. Some requests may be delayed. We are investigating the issue.
Posted Apr 10, 2026 - 12:59 CEST
This incident affected: Digisign (Queue).