Resolved: All email traffic to Microsoft-hosted mailboxes has recovered. We have verified stable performance and are now closing this incident.
Posted Sep 04, 2026 - 15:44 CEST
Update
Email delivery to Microsoft 365 / Exchange Online recipients has fully recovered and queued messages are being cleared. We are currently monitoring performance to ensure continued stability before fully closing this incident.
Posted Sep 04, 2026 - 15:15 CEST
Monitoring
Email delivery to Microsoft 365 / Exchange Online recipients has fully recovered and queued messages are being cleared. We are currently monitoring performance to ensure continued stability before fully closing this incident.
Posted Sep 04, 2026 - 15:10 CEST
Identified
Our mail provider has confirmed a widespread issue affecting email delivery to Microsoft 365 / Exchange Online mailboxes globally.
Microsoft’s inbound servers are returning temporary 451 4.7.500 Server busy responses due to receiving rate limits. All affected emails remain safely queued and will automatically retry delivery as Microsoft accepts incoming traffic.
We are monitoring queue throughput alongside our provider. No action is required on your part.
Posted Sep 04, 2026 - 12:39 CEST
Investigating
We are currently observing temporary delays in email delivery to recipients hosted on Microsoft 365 / Exchange Online servers.
Microsoft's inbound mail servers are rate-limiting incoming traffic from shared outbound mail pathways, resulting in temporary 4.7.500 Server busy responses. Affected emails remain queued and will be retried automatically until successfully delivered.
Our team is actively monitoring the queue status and delivery rates. No action is required on your part.
Posted Sep 04, 2026 - 11:08 CEST
This incident affected: External services (Mail service - Outbound Delivery).