Outage on E-mail delivery

Incident Report for Digisign

Resolved

The Mailgun team has resolved the issue and is monitoring mail service functions after the fix. All delayed emails are now being processed and will be delivered retroactively. For more information, visit the Mailgun status page: https://status.mailgun.com/
Posted May 25, 2026 - 15:08 CEST

Investigating

Some emails may not be delivered due to an outage on the mail service. Mailgun is currently investigating the issue. For more information visit Mailgun status page: https://status.mailgun.com/
Posted May 25, 2026 - 14:28 CEST
This incident affected: External services (Mail service - API, Mail service - Outbound Delivery).