PostSignum has successfully resolved the configuration issue on their servers. We have verified that their timestamp service is now fully operational again.
All systems are functioning normally, and our services have returned to their standard operations. We are now closing this incident.
Thank you for your patience and understanding throughout this disruption.
Posted Apr 10, 2026 - 13:02 CEST
Monitoring
The system adjustment to temporarily use I.CA timestamps has been successfully deployed. We are actively monitoring the envelope completion process, and we can confirm that everything is now functioning normally.
The envelopes that were previously stuck in the "Sealed" state are currently being successfully processed and completed. We will continue to monitor the situation until PostSignum fully resolves the root issue on their end.
Posted Apr 09, 2026 - 21:42 CEST
Update
We are currently working on a system adjustment to automatically apply I.CA timestamps instead of PostSignum to the affected envelopes. This will allow all envelopes currently stuck in the "Sealed" state to be successfully completed.
Please note that this is the exact same type of qualified timestamp, simply issued by a different qualified trust service provider. This will serve as a temporary solution until PostSignum fully resolves the technical issue on their end.
We will provide another update as soon as this fix is deployed and the pending envelopes are processed.
Posted Apr 09, 2026 - 20:39 CEST
Identified
We are currently experiencing disruptions with the PostSignum timestamp service due to a technical configuration issue on the provider's side. We are actively communicating with them to resolve this as quickly as possible.
Impact: This issue affects the completion of envelopes, which may remain in the "Sealed" state. Please be assured that once the provider fixes the error, all affected envelopes will be automatically completed.
Workaround: For new envelopes, we highly recommend switching to I.CA timestamps as an alternative to ensure your signing processes remain uninterrupted.
We apologize for any inconvenience caused by this third-party outage and will keep you updated.